Jump to content


Photo

Mossberg 930 failure to feed


  • Please log in to reply
2 replies to this topic

#1 Bacon

Bacon

    Finally read the FAQs

  • Classified
  • PipPip
  • 75 posts
  • Gender:Male
  • Location:Hartford, Connecticut

Posted 02 June 2009 - 07:49 AM

A friend of mine has a mossberg 930 spx. It functions perfectly with walmart 100 round boxes of 1/18 shot. When shooting 1oz. full power slugs it won't feed. The empty ejects, and the bolt closes on an empty chamber. If you manually cycle the bolt it feeds a round in. If the magazine is empty after firing a slug it will lock back the bolt. It sounds like its short cycling with slugs. Any ideas?

#2 StealthyBlagga

StealthyBlagga

    Special Little Snowflake

  • Classifieds
  • PipPipPipPipPip
  • 1,754 posts
  • Gender:Male
  • Location:The Uzi Triangle

Posted 02 June 2009 - 08:34 AM

A friend of mine has a mossberg 930 spx. It functions perfectly with walmart 100 round boxes of 1/18 shot. When shooting 1oz. full power slugs it won't feed. The empty ejects, and the bolt closes on an empty chamber. If you manually cycle the bolt it feeds a round in. If the magazine is empty after firing a slug it will lock back the bolt. It sounds like its short cycling with slugs. Any ideas?


My guess would be a phenomenon called "shell surge". The increased recoil of the slug load is causing the stack of shells in the magazine to slide forward momentarily. Thus, when the shell latch opens, the shell is not there to be released. Tell him to try with different quantities of shells in the mag; see if it works with (say) 1 shell versus with (say) 6 shells. The fix is to get a stronger magazine spring. Holding the gun really solidly can also reduce this phenomenon.

Edited by StealthyBlagga, 02 June 2009 - 08:36 AM.


#3 Bacon

Bacon

    Finally read the FAQs

  • Classified
  • PipPip
  • 75 posts
  • Gender:Male
  • Location:Hartford, Connecticut

Posted 02 June 2009 - 09:18 AM

A friend of mine has a mossberg 930 spx. It functions perfectly with walmart 100 round boxes of 1/18 shot. When shooting 1oz. full power slugs it won't feed. The empty ejects, and the bolt closes on an empty chamber. If you manually cycle the bolt it feeds a round in. If the magazine is empty after firing a slug it will lock back the bolt. It sounds like its short cycling with slugs. Any ideas?


My guess would be a phenomenon called "shell surge". The increased recoil of the slug load is causing the stack of shells in the magazine to slide forward momentarily. Thus, when the shell latch opens, the shell is not there to be released. Tell him to try with different quantities of shells in the mag; see if it works with (say) 1 shell versus with (say) 6 shells. The fix is to get a stronger magazine spring. Holding the gun really solidly can also reduce this phenomenon.



I'll let him know. That would make sense because I know he put a prototype mag extension on it, and had trouble with the spring.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users